| Debian codeame | Status | Version | Stable release | LTS support until |================= | squeeze | unsupp | 6 | 2011-02-06 to 2014-07-19 | 2016-02-29 | wheezy | unsupp | 7 | 2013-05-04 to 2016-06-04 | 2018-03-31 | jessie | unsupp | 8 | 2015-04-26 to 2018-06-23 | 2020-06-30 | stretch | lts | 9 | 2017-06-17 to 2020-07-18 | 2022-06-30 | buster | lts | 10 | 2019-06-06 to 2021-10-09 | 2024-06-30 (planned) | bullseye | stable | 11 | 2021-08-14 to ??? | 2026-06-30 (planned) | bookworm | testing| 12 | none yet | none yet | sid | unstable |

Sources: https://wiki.debian.org/DebianReleases https://wiki.debian.org/LTS